Or call our technical support: +31852080825

Available Monday through Friday from 7AM to 3:30PM CET
Please create a ticket before calling and keep the ticket number at hand.
At the moment we are only offering support in English, so we kindly ask you to address your issue in English.
Start a new topic
Solved

Upgrade Power Supply Creatr

Hi,


Just wanted to post this in case anyone else runs into a similar issue. I looked all over for the specifications on the power supply of the Creatr Dual Extrusion model. Finally i just ripped mine out to upgrade it.


Stock Supply:

Wei Hao S-400-24

24V 17A


I replaced my supply with a Mean Well HRP-600-24 for roughly $135 USD. The supply is a 600 Watt 24V 27A. 


This has increased my heating speeds half the time and can maintain proper heat for ABS. The Creatr is advertised as ABS compatible but can hardly reach the temperatures to get any good prints. I'd be ashamed of this false advertisement If I worked or designed systems for lpfrg. They should really look into upgrading the power supplies to at least 24V 25 Amps. The end user would be much more satisfied and would come out with better prints.


I've had my printer torn apart and put back together about 25 times in the past 2 years. 75% of the stock hardware has been replaced just due to how short of a lifespan it has. I will say the precision ground ball screw system on the Z-Axis is very good. The only time i have had a bad part was due to lack of heat, when its stable it prints very good quality. When paired with the Simplify3D software, a good set of tools, and a solid education in CNC machines... this printer is one of the best out there. 


1 person has this problem

Hey, 


Good tip, I was just wondering about the heated bed. it takes forever to heat up. 


What temperature can you reach ? 


What other parts has you replaced? 


I've had my printer for barely three months and I'm looking into geared extruders (bowden and direct drive isn't ideal it seems, or mine is just in need of adjustment, the feed seems seriously wrong). 


New hotend, to avoid clogging, preferably groove mount.


Better quality X/Y axis 10-12mm, straight ones this time.


More rigid bottom plate for the glass bed, the current one is seriously wobbly.


Higher precision adjustment for heated bed, M8X1 for instance, perhaps even finer pitch. 


Relocating the X-axis motor to make room for a pair of groove mount hotends and still maintain full width in X-motion. 


Ohh and replacing the plastic belt pulleys for bearing ones, the original started to squeak with in a week on my printer. 


Part from this, maybe a couple of Watterott drivers and while one is on a run, why don't change the controller board as well.



the list goes on......




Hi John,

I just found out that the original power supply in my Creatr has shorted out. Exactly 2 years after purchase.

I really like the idea of upgrading the power supply, which should alleviate issues with constant temperatures, both bed and extruder.

Have you have any issues after upgrading?

Do you mind discussing off line via email or chat? tigger.japan@gmail.com

 

 Hi John,


Can you post any updates? Is the printer running fine with the additional power?


I'm about to replace a dead power supply with a Mean Well 450W.

Changing the powersupply on your printer to a bigger one (600W) means the currents that run through the wires (e.g. to your heated bed) will be higher than the wires/connectors were initially designed to handle, you are risking a fire that way!

 

Hi Jeff,


David is correct on having to replace wire gauges.. It just depends on what size your are changing to. Be sure to check out a wire gauge chart online before upgrading, Its not too hard to re-wire the system.

On my current system, i have replaced everything but the mechanical components. I replaced the head with a better head off of Amazon.com. Not sure if anyone else had an issue, but the stock head was a pain in the ass to load. I have also invested about $2000 in a better controls system. I replaced all the stepper motors with Beckhoff industrial steppers, and replaced the stock NC controller board with a better Beckhoff PC controller. 

I'm a software engineer for a CNC machine manufacturer, the one this printer comes with is shit compared to our systems... I just had to upgrade it. Since then, i very rarely have a bad print. About 90% of our business is building privately branded machines for Swiss companies, and their engineers are very fastidious on what they want in a machine. When I bought this printer, I made a harsh generalization by assuming most of Europe was the same way haha.

 Thanks for the information.


I'm more concerned about the heated bed. Does the stock bed handle the increased power? You mentioned 1/2 time to heat the bed, which means a lot more power is going the those heaters.


FYI, I'm moving to 450W power supply. It's a far better power supply (5 year warranty), and should help keep the heaters (all) more stable during printing.

From this site, it looks like the stock cables will handle the 450W at 24V.

http://www.solar-wind.co.uk/cable-sizing-DC-cables.html

 

From this site, it looks like the stock cables will handle 450W at 24V.

Cable Sizing

 

From this site, it looks like the stock cables will handle 450W at 24V.


Cable Sizing



I found on my machine the problem with the bed was caused by the silver connectors. The connectors oxidized and then burned along with the wires. I recieved a new bed and then hardwired it in bypassing the connectors. The bed now works great l
Thanks for posting this. I have two leapfrog creator's. Bed heats up slowly and support from Leapfrog has been pretty good (they shipped me new parts etc). I did get a great deal on a Mean Well HRP-600-24 From eBay dirt cheap. But I think I will try the bypass on one and the new power supply on the other. I'll let ya know.
Check all the wire ring from the bed to t h e power supply. You must remove the nylon cover to see the wires. Unfortunately the cover hides t h e wires so you can not see th r b burn. Once the cover is removed you can clearly see any damage.
Hi Guys, Daniel from Belgium, Antwerp. My axis XYZ and filament feeding does not work, moves. Can it be due power supply ? The communication works, while the heating bed and extruders heatings do work. I am desperate becauce i don't printed any piece yet and i have the thing already a year. Becauce it did not work properly at the first time i let it in the corner of my workshop and now i have moer time i wanted re-start the intention to print. So this "sucks" a lot. Thank u for any advice . Daniel
First, before you do anything else, HOME X/Y and HOME Z Does that work?
Login or Signup to post a comment

User Manuals

Quick Start Guide

Print Settings

Demo Print Downloads

Drivers Downloads

Software Downloads

Firmware Downloads

Please request a firmware download via the Ticket System

Creatr HS Video Library