Or call our technical support: +31852080825

Available Monday through Friday from 7AM to 3:30PM CET
Please create a ticket before calling and keep the ticket number at hand.
At the moment we are only offering support in English, so we kindly ask you to address your issue in English.
Start a new topic

Y-Axis Stepper Does Not Respond

Basically as the title says, my Y-Steppers (both of them) are not responding anymore. 


Tried reflashing the old firmware (1b) and still does not work. Waiting on the new firmware from 


leapfrog support.


Any other possible solutions?


Has this happened all of a sudden? Have you tried restarting your printer, disconnecting it from Simplify, removing the usb cable and the plugging it back in? As well, you can also try pressing the reset button from the electronic board.

Yes, over night it just stopped. Leapfrog support said it's the board that burnt out. But I'll definitely try your suggestion. Will let you know.
Login or Signup to post a comment

User Manuals

Quick Start Guide

Print Settings

Demo Print Downloads

Drivers Downloads

Software Downloads

Firmware Downloads

Please request a firmware download via the Ticket System

Creatr HS Video Library