Or call our technical support: +31852080825

Available Monday through Friday from 7AM to 3:30PM CET
Please create a ticket before calling and keep the ticket number at hand.
At the moment we are only offering support in English, so we kindly ask you to address your issue in English.
Start a new topic

Not very pleased at this moment

Having build 3 printers myself, for home use, the time was right to buy a printer for my professional job. I design machine parts, and 3D printing helps me a lot!!


Because of the building and tuning a self made printer cost, i decided to buy a prebuild machine. My choice was the Creator HS (dual nozzle, large build volume, and a good demo in the leapfrog headquarters!!


But after installing and using the machine for 2 weeks now, I have all sorts of problems, which i did not expect from a prebuild machine.

-I have a lot of filament jams (the pro series pla of leapfrog), usualy after several hours, where the reason of malfunction is sometimes difficult to detect. But i am 100% sure, that the filament support wheels, just sucks, being horizontaly, no "break" system, and not the correct spindle size, it is jamming like hell. A printer in this price range should have solutions for this. (and i don't accept thingiverse solutions!)

-I also bought the case, and when i use this, closed, i get filament jams in the extruder, even with the flexible adapter piece.

-The motors get hot, like almost burning fingers.

-The printer is so loud, the motors seem to be overpowered, and i can hear the bearings rattling. This printer is not usable in my working space, have to put it in another room.

-The display is so difficult to use, turning the button jumps in the menu's to fast, sometimes i make wrong selections.


And, until now, several rolls of filament used, the output is not like i want it to be, the pieces are not strong enough (compared to the output off my self build machines), but once most off the above problems are solved, i hope to get it in good working shape.


I anyone has any tips, i gladly hear them ;-)



Dear Rudy de Geus,


I would like to try and address the issues you have presented.


My first question is regarding the type of filament you are using for the prints ABS, PLA?


Next is what software are you using to slice the gcodes and what settings? Would you agree to send me a factory file of a model you wish to print so I can adjust the settings based on the model and that way you can see what changes I made?


It does not have to be something you designed as I am sure you would not like to release something like this.


The cover I would suggest using only for ABS prints as for PLA or other types of material the excessive heat will damage the quality of the part and even produce issues with extrusion. Only ABS prints can benifit from a enclosed chamber.


Regarding the noise from the bearings could you send me a recording or a video of the printer working so I can hear the noise it is making?


I look forward to hearing from you.



Hello Mircea,


First the Jams:

I print pla with closed cover, and yes, it seems to get to hot. When i remove the cover the quality is better, and the jams are less. 

Part of the jams came from 1 extruder, which will be replaced soon ;-). After that, i think this issue is solved.

Also, the new bearings are on the way, so this issue of the noise will be solved to...

So, for now, i wait for the parts, when they are on the machine, i will update this post.

Thanks for the support until now.


Rudy


Thank you for the update Rudy I will make sure to watch the thread and reply to any questions.

Dear Rudy and Mircea,

 

We have the same issues with a 2015 Xeed extruder. Overheating motors and curling in the head. Despite 4 fans are spinning we suffer from jams after more than half hour of printing. Seems a structural problem, not to be expected using this sort of expensive machine.

 

We are unpleased with the progress so far also. The adjustment of the tension on the wheels of the extuder is vague and not easy to adjust.

 

This issue needs attention and a solution!

 

 

JPG
(656 KB)

I've just purchased a Xeed and now seeing all these reports fills me with dread.


Has nobody had a good experience with these machines?

So the forum is also dead?


Did I make the right choice paying €7000 for a Xeed?


I have not seen a single positive review (apart from those selling this printer).


I WILL refuse delivery tomorrow if there are no reassurances.

Hey Rudy,

I have the same issue. PLA is bending behind extruder roll but before entering hot end. I opened the ticket for this, and so far I was advised to re-align extruder (which helped a little - it doesn't jam every 20 minutes, not every 10, so 50% improvment) and to exchange fans and but new nozzles. I guess the problem lies in islotaing heating block. Heat radiating up softens filament and jams it. Heat radiating down - softens the print and makes it look bad. It is not contained in any way - if You check E3D or J-head (aka best known RepRap hotends) You can see that they both have cooling part on top. When I receive my thermocouple I will make some measurements and let You all know.


have a good printing!
TP

Login or Signup to post a comment

User Manuals

Quick Start Guide

Print Settings

Demo Print Downloads

Drivers Downloads

Software Downloads

Firmware Downloads

Please request a firmware download via the Ticket System

Creatr HS Video Library