Or call our technical support: +31852080825

Available Monday through Friday from 7AM to 3:30PM CET
Please create a ticket before calling and keep the ticket number at hand.
At the moment we are only offering support in English, so we kindly ask you to address your issue in English.
Start a new topic

Issues with peripherical device - FTDI Driver

( In advance, apologise for my english, hope everything goes clear ! )

Hi, i actually have some strange issues with my printer.

I've started by downloading multiple software for compare config and slicing performance. I've installed Simplify3D, Repetier Host and Creatr 1.0 ( Materialise, i've no license for now but i've already installed it )

With materialise, i've seen that have install some side software like "Build Processor System", I've add the printer in ( Creatr HS dual ) and seen they have some good stuff in it, like Head Alignement tools and stuff.

After looking at all this stuff, i've connect my printer and see that any software cant connect to it. After a fast review, i've found on the Leapfrog support i miss a FTDI Drivers, i've Downloaded and install it ( FTDI 232 HL or things like this )

Until i've installed this drivers, the software can connect to my printer correctly ( Simplify and repetier ) but the Build Processor one seem to be broken, the printer i've had have disappeared and i get a error message when i refresh ( Look the attached files, sorry, is in french )

I actually can print but cant use all the tools i have, and it's kind of disappointed ... Instead of this problem seen to be more deep than just this.

If someone know what happen and how i can solve this, i'll be really cool ! ( The only things i've found about this FTDI Driver is very alarming, like it's an very, very bad driver that can kill the FakeChips ... Don't realy know what that mean but it's not reassuring )

jpg
1 Comment

Thank you for your feedback. I need to first clarify something with a true and genuine response so as to not get get everyone that reads this forum article in a panic:


Our Creatr HS motherboards are designed by Leapfrog 3D Printers, and we have the supplier check every FTDI chip to make sure that it is not the "Fake Chip," as you say. We are aware of the issue and have taken steps to make sure that your Creatr HS does not have it. So no worries.


The issue that you are experiencing quite possibly is something else. I see that you've created a ticket on it in our support system (which is the fastest way to resolve the issue), so I look forward to assisting you further through the ticket. Feel free once we resolve the issue to let everyone know here in the forum what we found to be the cause, as it very well may help others with the same issue. Thanks again for using our forum - now let me quickly get to your ticket. ☺


Many Thanks,


Aaron C. - Leapfrog Technical Support Agent


Login or Signup to post a comment

User Manuals

Quick Start Guide

Print Settings

Demo Print Downloads

Drivers Downloads

Software Downloads

Firmware Downloads

Please request a firmware download via the Ticket System

Creatr HS Video Library